Pick Job system degraded

Incident Report for BladePRO

Resolved

This incident has been resolved
Posted Oct 29, 2025 - 11:39 GMT

Monitoring

Error backlog cleared, continuing to monitor.
Posted Oct 29, 2025 - 11:37 GMT

Investigating

We are currently experiencing a high volume of errors on our pick job allocation system, we are currently investigating
Posted Oct 29, 2025 - 11:16 GMT
This incident affected: Web App.